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I. PopDrive Features 

 

Thank you for purchasing the PopDrive. We created the PopDrive to give you a small, fast, and 

portable external hard drive that you can safely save your data on. Many people are expanding 

the data storage on their computers by buying external hard drives. The only problem with that 

strategy is that 99% of all of the external hard drives out there have the same problem as internal 

hard drives. Sometimes they crash and the user loses all of their data. 

While the PopDrive has a number of great features, the main feature that we believe that you are 

going to use it for is the safety function of having dual hard drives. When configured and 

operated correctly, you should never lose your data, even if a single hard drive fails. 

Here is the short list of features of the PopDrive: 

1. The PopDrive holds two Sata hard drives. 

2. While the PopDrive is currently sold with either 500Gb or 750Gb hard drives, it is 

upgradable with any 2.5” Sata hard drive that is no more than 10.5mm high. 

3. When configured in RAID1 mode, all data is copied to both hard drives at the same time. 

The drives will be mirror images of each other. 

4. Supports RAID0 and JBOD mode as well. 

5. When loaded with two hard drives, it weighs about 21 ounces. 

6. The PopDrive has a USB2.0 and eSata port. 

7. When operated via eSata, the hard drives are hot-swappable. 

8. The PopDrive includes the SteelVine management software package. 

9. The SteelVine software is used to configure the PopDrive. 

10. The SteelVine software is configured to inform the user of a number of events on the 

PopDrive including: hard drive failure, connection and removal from the computer, 

device temperature, and more. 

11. When set up, the SteelVine software can send e-mail notices of the events listed above. 

A. Notes for non-Computer Gurus 

 

Most non-Computer people will appreciate the fact that the PopDrive will appear as a single hard 

drive on your computer. This makes it very easy to use. It is important to note that it also 

operates like any other hard drive as well. If you delete a file from the PopDrive, it will be 

deleted from both hard drives. Please keep this in mind.  

If your goal is to prevent data loss from accidental deletion, we strongly recommend that you 

implement a backup software program with the PopDrive or consult a computer professional. 

The safety features of the PopDrive are designed to keep you from losing data in the event of a 
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hardware failure, not user error. Backup software like Apple’s Time Machine or Roxio’s 

Retrospect are designed to protect from the loss of data due to user error. These backup software 

programs as well as many others are fully compatible with the PopDrive. DHK Storage has 

chosen to not include backup software with the PopDrive for the following reasons: 

 Doing so would unnecessarily raise the cost of the PopDrive. If you already have a 

backup software package that you like to use, you would be paying for something that 

you don’t need. 

 We do not want to limit you to a software package that is bundled with the device. At the 

popdrive.com store, we offer a number of backup software packages that work well with 

the PopDrive. 

 Backup software is not necessary to take advantage of the hard drive mirroring function 

of the PopDrive. Please note, backup software is only necessary if you are looking to 

protect yourself from the accidental deletion of data. 

The first time setup of the PopDrive can run as long as 10 – 15 hours depending on the size of 

your hard drives. Most of this time is spent on the mirroring of the hard drives for the first time. 

We suggest that you begin the process at night so that you can use the PopDrive the following 

morning. The first time setup does require a little patience, but the safety that the device provides 

is worth it. 

Last, many non-computer users are not familiar with setting up a mirrored hard drive system. 

Please read through the Quick Start guide carefully. If you have any questions or are unsure of 

what you are doing, please go to the popdrive.com website. There are a number of support 

guides and venues available there. 

B. Notes for Computer Gurus 

 

If you are reading this section you are probably very familiar with RAID1 array setups. The 

quick start guide below should be easy for you to follow. There is nothing out of the ordinary in 

our process versus any other RAID1 setup you have performed. 

The best features of this device that you should implement are the e-mail alerts. If setup 

correctly, you should be able to receive notices from all of your customer’s PopDrives. This will 

allow you to be informed when the correct PopDrive is attached to the customer computer, when 

it is removed from the computer, and let you know when a hard drive fails. If you point all of 

your customer’s PopDrives to a single e-mail account, you will be able to manage your customer 

backups and hard drive arrays better than 99% of your competitors. 

In addition, the PopDrive keeps an internal event log. Please see the section, “Event Log” later in 

this manual for details. 
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Last, it is important to note the SteelVine management software installs itself both as a system 

tray program and as a Windows service (daemon). 

If you have any questions about the PopDrive, please see the support offerings at the 

popdrive.com website. We do offer different levels of support for PopDrive resellers. Please see 

the website for details. 

C. Known Issues / Future Software Releases 

 

DHK Storage is aware that the SteelVine manager for the PopDrive is somewhat complicated for 

the general computer user. We are in the process of developing an easier version of the software 

that should be released in the summer of 2011. If there is a feature that you would like to see in 

the future program, please let us know. Our goal is to make the management software as 

functional and easy to use as possible. Please send your suggestions to features@popdrive.com.  
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II. Quick Start Guide 

A. Installation Overview 

 

In order to get up and running with your PopDrive, here is an overview of the first-time 

installation of the device: 

1. Install the PopDrive Management software onto your computer. 

2. Insert the hard drives into the PopDrive. 

3. Connect the PopDrive to your computer. 

4. Insert the power connector into the PopDrive 

5. Build the hard drive array 

6. Verify the hard drive array 

7. Create the drive partition 

8. Format the partition 

When the partition has been formatted, the PopDrive will appear like any other hard drive on 

your system. Please remember that once this is done, even though it will appear as one hard 

drive, your data will always be copied onto both hard drives at the same time if you set it in 

RAID1 (SAFE) Mode. 

You can always check the status of the hard drive configuration of the PopDrive by running the 

SteelVine management software. 

B. Software Installation 

 

Once you have inserted the CD into your computer, please navigate to the folder matching the 

operating system of your computer. Inside each folder is an appropriate program to execute that 

will install all software drivers and management software for the PopDrive. 

After installing the software, you must restart your 

computer before moving on to the next step! 

C. Inserting the Hard Drives 

 

In order to open the hard drive doors, use your fingernail to slide the silver latch downwards 

(towards the opposite side of the door or the hinge). 

Once the door is open, slide the hard drive in until it rests on its own. Do not force or push the 

hard drive into place. Tilt the PopDrive drive vertically so that the hard drives fall to their natural 

resting point. When the hard drive is resting in place, close the door. As you close the door, the 

hard drive will automatically slide into the proper location and attach to the internal connector. 
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When the door is nearly closed, you should encounter a small amount of resistance and then 

click when complete. 

Please use the following picture to make sure that you have put the hard drives in correctly.  

 

When the door hinge is on the right, the hard drive label side should be facing up. If you attempt 

to install the drives upside down, the PopDrive doors will not close. 

D. Connecting the Data Cable – USB or eSATA? 

 

On the back of the PopDrive, there are two data ports, one is USB2.0 and the other is eSata. 

There are a number of differences between the two. The USB port runs at 480Mb/s and is one of 

the most common data ports available on computers today. If you don’t have an eSata port on 

your computer, you should plug the PopDrive into the USB port. 

WARNING - It is very important that you do not disconnect the PopDrive from your 

computer without safely removing it from your computer when using the USB cable. Not 

following this step can potentially cause damage to the data on your PopDrive. There are a few 

ways to safely remove the PopDrive. Please see the section in this manual titled “Safely 

Removing the PopDrive from your Computer”. 

There are some big advantages for using the eSata port if you have one on your computer. If you 

don’t have one, please go to the popdrive.com website to find a compatible eSata card for your 

computer. 

The best feature of eSata is speed. An eSata port runs at 3Gb/s. In addition, when using the eSata 

cable, the hard drives are hot-swappable. This means that you can remove an unused or bad hard 

drive while the PopDrive is connected to the computer. You can also add a new hard drive while 
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the PopDrive is connected as well. Please remember, this only applies when you have connected 

the PopDrive to your computer with an eSata Cable. 

WARNING – DO NOT CONNECT AN ESATA AND USB CABLE TO THE POPDRIVE 

AND YOUR COMPUTER AT THE SAME TIME. DOING SO RISKS DAMMAGING 

THE DATA ON THE POPDRIVE AND YOUR COMPUTER. 

E. Create the Hard Drive Array 

 

1. Select Configure Box from the Edit menu or click the Configure Box toolbar button to 

open the Basic Configuration Wizard.  

 

2. When prompted, enter the administrator password. The default password is admin.  
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3. Select a storage policy in the Storage Policy frame.  

 
 

Even though the picture shows the BIG policy, we strongly recommend using the SAFE (RAID 

1) policy. 

Policy  Description  

SAFE (RAID 1) RECOMMENDED 

Creates one volume. One hard drive mirrors 

the other. The system automatically restores 

data redundancy to a SAFE volume when an 

offline drive comes back online.  

JBOD (bypass)  

Creates a logical volume for each physical 

hard drive. Available only for SATA host 

controllers that provide Port Multiplier 

support, and only available for the top-level 

node of a cascaded configuration.  



8 

 

BIG  
Concatenates all hard drives into a single 

volume.  

SAFE33  Not recommended for the PopDrive.  

SAFE50  Not recommended for the PopDrive. 

FAST (RAID 0)  Not recommended for the PopDrive. 

 

 

4. When prompted to acknowledge that the configuration change may result in data 
loss, click Yes to accept the configuration.  
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5. Select Save to Config File from the File menu or click the Write configuration 
for system to a file toolbar button to save the configuration.  

 
 

Even though the picture shows the BIG policy, we strongly recommend using the SAFE (RAID 

1) policy. 
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6. Click Apply to create the selected configuration, close the Wizard, and display the 
volumes in the Status Window (may take up to one minute to display).  

 
 

Even though the picture shows the BIG policy, we strongly recommend using the SAFE (RAID 

1) policy. 

 

7. Partition the configured volumes to complete the implementation. Refer to section 
II-G Create and Format the Drive Partition for details.  

 

F. Verify the Hard Drive Array 

To confirm that the two hard disks that comprise a single SAFE (RAID1) volume are exact 

copies, you can execute a Verify Disk task manually.  



11 

 

 

When the SteelVine manager is open and you select “Start Verify”, there is a 60 second delay. 

The “Start Verify” selection will be disabled during this time. Otherwise, if the drive is in 

normal or verify abort mode, you can manually start the verify operation.  

 

A pop-up will inform you of the action taking place. 
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G. Create and Format the Drive Partition 

You must partition volumes for the host computer’s operating system before you can store data 

on the volumes. Refer to the operating system’s documentation for further guidance.  

On Windows 

 

1. Right-click the My Computer icon on your desktop and select Manage from the 
pop-up window.  
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2. Select Disk Management under Storage to open the Windows Disk Manager. 
This example illustrates the SAFE storage policy, which duplicates the data on 
both hard drives connected to the PopDrive. Every disk should appear with the 
word “Basic”, a size value that shows the available storage capacity, and a 
status of “Online”. Instead of Basic, a disk could appear Unknown, Dynamic, or 
Not Initialized.  

 

If the disk appears as “Unknown”, right-click the disk icon and select Write 
Signature. A window opens with the selected disk (all Unknown disks may 
appear in this window). Make sure the box next to each disk is checked and click 
OK. The disk should now be marked as a Basic disk.  

If a disk appears as “Dynamic”, right-click the disk icon, and select Revert to 
Basic Disk. Within a few seconds, the disk should be marked as a Basic disk.  

If a disk is marked “Not Initialized”, right-click the disk icon and select Initialize 
Disk. An additional dialog box appears allowing you to select which disks to 
initialize. Uncheck the SteelVine Processor Disk item and click OK. Within a few 
seconds, the selected disk(s) should be marked as a Basic disk.  
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Note: The disk numbers in the Windows Disk Manager may be different from the Volume 
numbers shown in the SteelVine Manager Status Window, Basic Configuration Wizard, or 
Advanced Configuration Wizard. Be sure that you select the correct disk based on the 
expected disk capacity to create a partition.  

 

3. Right-click the configured disk’s unallocated space and select New Partition. If 
the New Partition option is not available, select the disk and initialize it first. To do 
this, right-click on the disk item and select "Initialize Disk".  
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4. Click Next to start the Partition Wizard.  

 

5. Select the Primary or Extended option and click Next.  
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6. Specify the partition size. By default, the partition occupies the entire volume. 
Click Next. 

  

7. Assign a drive letter or mount path and click Next.  
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8. Name and format the partition and click Next.  
 

 

9. Review the file system settings and click Finish to create the logical partition.  
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10. Repeat steps 1 through 9 to partition any remaining disks you configured in the 
SteelVine Manager GUI.  
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On Macintosh 

Important: If no hard drives are connected to the Storage Appliance, the SteelVine Processor disk 

(8.0 GB Config Disk Media) will appear. Do not remove or modify that partition. 

  

1. Launch Disk Utility from the Application > Utilities folder.  

 

2. Select a configured disk and click the Partition tab. This procedure illustrates the 
BIG Storage Policy configuration, which concatenates the capacity of all hard 
drives connected to the PopDrive.  
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3. Select 1 Partition from the Volume Scheme drop-down list.  

4. Enter a name for the volume in the Name field (such as “My BIG disk”.)  

5. Select Mac OS Extended (journaled) from the Format drop-down list.  

6. Specify the size of the partition in the Size field.  

7. Click the Partition button.  

8. Click Partition to acknowledge the warning.  

 

Disk Utility mounts the created partition and represents it with an icon on the 
desktop. The icon is labeled with the partition name.  

9. Repeat steps 1 through 8 to partition any remaining disks you configured in the 
SteelVine Manager GUI. Remember, do not partition the disk that represents the 
SteelVine processor.  

 

On Linux 

 

Note: For a more detailed instruction to install the SteelVine Manager, please refer to the Quick Installation Guide 

for Linux. 
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III. Using the SteelVine Manager 

 

A. Running the SteelVine Manager 

Windows  

Click Start > Program Files > Silicon Image > 57XX SteelVine > SteelVineManager. Once 

started, the SteelVine Manager Application icon can be found in the Notification Tray located at the 

bottom right hand corner of the screen. Double click the notification tray icon to open the SteelVine 

Manager GUI status window. The SteelVine Manager icon remains active in the notification tray 

even if you close the SteelVine Manager window. It can be closed by right-clicking on the icon and 
selecting “Exit”.  

 

The SteelVine Manager starts with the Status Window visible so you can monitor the PopDrive(s) 

connected to the host computer. Up to four PopDrives can be managed through a single session.  

 

Select menu options and follow the instructions in the remainder of this guide to configure the 

PopDrive. When prompted, enter the administrative password (default password is admin).  

Mac OS X  

The SteelVine Manager software is installed in the Applications > Utilities > SteelVine folder. 

Before the SteelVine Manager starts, the launch sequence searches for an active daemon and 

launches it if the daemon is not active.  

1. Launch the Finder and navigate to the Applications > Utilities > SteelVine folder. 

Double-click the SteelVine icon to start the SteelVine Manager.  
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2. If the launch sequence does not find the daemon, a warning message appears. Click OK.  

 

3. Enter the system administrator (root) password and click OK.  

 

4. A notice appears as the launch sequence attempts to start the daemon. Click OK.  

 

If the daemon fails to start, an error appears. Follow the recommendations in the error 

message to correct the problem.  
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5. Monitor the status of PopDrive(s) on the Status window.  

 

6. Select menu options and follow the instructions in the remainder of this guide to configure 

PopDrive(s). When prompted, enter the administrative password (default password is 

admin).  

 

Linux  

Use the following procedure to launch the SteelVine Manager on a Linux system.  

1. Change to the directory in which the SteelVine Manager GUI and daemon software was 

installed (such as /usr/local/SiliconImage)  

2. Start the daemon by entering the command: ./SiI57XX -e  

3. Open a new terminal window and start the GUI by entering the command: ./SiI57XXUI 
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B. The SteelVine Interface 

The SteelVine Manager starts with the Status window visible so you can monitor the PopDrive. 

 

Note: The appearance of this screen will vary depending on the current Storage Policy. Refer to the tables below for 

a description of which items appear. 

Status Cells  Description  

Topology Section  

Device Listing 

All PopDrives that are attached to the 

computer will have their serial number listed in 

the Topology column on the left side of the 

window. 

System Status Section  

Temperature  

Indicates the current temperature of the 

PopDrive. The field displays “N/A” if there is 

no temperature sensor installed in your storage 

enclosure.  

Fan Speed  

Indicates the system fan state. The field 

displays “N/A” if there is no fan speed sensor 

installed in your storage enclosure.  

Drive Status Section  

Box Status  

Shows the drive state: Normal, Rebuilding, 

Verifying, Unplugged, Needs Rebuild, New 

Drive, Wrong Slot, Use Bigger Drive, 

Mismatch, Not Readable, Locked or 

Unavailable.  
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Drive S/N  
Shows the unique serial number assigned by 

the disk manufacturer.  

Exp. S/N  

Shows the expected serial number. The 

PopDrive compares the expected and actual 

drive serial numbers to detect when a drive’s 

status changes.  

Capacity & Volume Information Section  

Policy  

Shows the storage policy configured for each 

volume. If the volume is in any state other than 

“Normal”, the additional status information 

will also appear in this item.  

Total  Shows the combined capacity of the volume.  

Capacity  
Shows the amount of storage space (in GB) 

available on each hard drive.  

Volume  
Shows the total volume capacity and the drive 

capacities assigned to each volume.  

 

File Menu Item  Description  

Change Password  
Opens a dialog to establish a new 

password.  

Scan Devices  
Refreshes the status details presented on 

the Status window.  

Change Connections  
Opens a dialog to establish remote 

connections.  

Quit  
Exits the SteelVine Manager GUI 

(Windows systems only)  

 

Edit Menu Item  Description  

Configure Box  Opens the Basic Configuration Wizard.  

Schedule Disk Verify  
Schedule a disk Verify activity (enabled only 

in SAFE mode)  

Configure Pop-Ups  

Configure the Pop-Up messages. This selection 

is only available for the top-level node of a 

cascaded configuration.  

View Policy Settings  

Display the Rebuild policy settings. This 

selection is only enabled when using SAFE 

(RAID1) mode.  

Setup Email Notification  
Opens the Setting-up Email Notification 

dialog.  

Event Log  Opens the Event Log viewer.  

Specify Firmware  Opens the Firmware Selection dialog. 

Backup Button  Not used by the PopDrive. 
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These selections are only available when one SAFE volume has been configured on the system. 

Edit Menu Item  Description  

Start Rebuild  Initiates a Rebuild to the target drive  

Start Verify  
Initiates a Verify activity on the selected 

drive  

Abort Rebuild  
Abort the rebuild process (only selectable 

when a Rebuild operation is active)  

Abort Verify  
Abort the Verify process (only selectable 

when a Verify operation is active)  

 

Button  Tooltip  Description  

 
Configure Box  Opens the Basic Configuration Wizard.  

 

Schedule Disk 

Verify  

Schedule a disk Verify activity. This selection only appears when one 

SAFE (RAID1) volume exists.  

 
Configure Pop-Ups  Configure the Pop-Up messages.  

 

View Policy 

Settings  
Shows the Rebuild Policy.  

 
Show Event Log  View the Event Log.  

 
Specify Firmware  

View the current version or download an updated version of the 

PopDrive firmware.  

 
Email Notification  

Configure the operation of email message notification. This selection 

is only available for the top-level node of a cascaded configuration.  

 
Backup Button  

Not used by the PopDrive. 

 

 

C. Basic Configuration 

 

To access the Basic Configuration Wizard, click on the Configure Box icon along the 
top of the SteelVine Manager Status Window.  
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To protect against unintended changes, the SteelVine Manager prompts for a password 
the first time you access the Wizard. Enter the administrator password. The default 
password is admin. (See Change the Password in section III-K for additional information 
on password management.)  

 

The Basic Configuration Wizard dialog will appear (see Figure 11 below).  
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Wizard Section  Description  

Storage Policy  
Identifies available SteelVine Storage Policies 

to assign to the PopDrive.  

Volume List  

Shows Volume, Mode (storage policy), and 

Size details for logical volumes.  

The “Total GB’s Left” field (below the 

volume list) shows the remaining capacity in 

gigabytes for all hard drives.  

Drive Graph  

Displays disk space for each hard drive. 

Storage capacity that is allocated to the same 

volume appears in a matching color. A hatch 

pattern indicates a proposed configuration and 

a solid block indicates an existing volume.  

The “Cap” field (below each drive in the 
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drive graph) shows the maximum capacity in 

gigabytes for that hard drive.  

 

Button  Tooltip  Description  

 

 

Read a configuration 

from a file  

Reads a saved configuration into the Basic Configuration 

Wizard so you can apply the configuration to the PopDrive.  

 

Write configuration from 

system to a file  
Save a Configuration File to a file on the host computer.  

 

Restore configuration to 

last commit  
Cancels proposed changes.  

 

Button Label  Description  

To Advanced Mode (NOT RECOMMENDED) 

Opens the Advanced Configuration Wizard. 

This option is only available if the Advanced 

Configuration mode is enabled for you system. 

If you are using a SATA host connection, this 

option is only available if your SATA 

controller is PM-aware. 

Apply  

Submits configuration changes to the 

PopDrive, closes the Wizard, and displays the 

updated configuration on the Status Window.  

Cancel  Aborts the changes and closes the Wizard.  

 

Configure Volumes  

Note: Before reconfiguring the PopDrive, you must delete any previously defined partitions. See 
Partition a Volume for details.  

1. Select Configure Box from the Edit menu or click the Configure Box toolbar button to 

open the Basic Configuration Wizard.  
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2. When prompted, enter the administrator password. The default password is admin.  

 

 

3. Select a storage policy in the Storage Policy frame.  
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Policy  Description  

SAFE (RAID 1) RECOMMENDED 

Creates one volume. One hard drive mirrors 

the other. The system automatically restores 

data redundancy to a SAFE volume when an 

offline drive comes back online.  

JBOD (bypass)  

Creates a logical volume for each physical 

hard drive. Available only for SATA host 

controllers that provide Port Multiplier 

support, and only available for the top-level 

node of a cascaded configuration.  

BIG  
Concatenates all hard drives into a single 

volume.  

SAFE33  Not recommended for the PopDrive.  

SAFE50  Not recommended for the PopDrive. 

FAST (RAID 0)  Not recommended for the PopDrive. 

 

 

4. When prompted to acknowledge that the configuration change may result in data 
loss, click Yes to accept the configuration.  
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5. Select Save to Config File from the File menu or click the Write configuration 
for system to a file toolbar button to save the configuration.  
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6. Click Apply to create the selected configuration, close the Wizard, and display the 
volumes in the Status Window (may take up to one minute to display).  

 

7. Partition the configured volumes to complete the implementation. Refer to section 
II-G Create and Format the Drive Partition for details.  

 

D. Advanced Configuration 

 

Even though there is an advanced configuration button available in the SteelVine manager, we 

recommend that you do not use it. The SteelVine advanced configuration allows you to have 

multiple partition types on the PopDrive. We believe that this is a level of complexity that is not 

necessary for most PopDrive implementations. 
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In future releases of the PopDrive management software, the advanced configuration features 

will not be available. 

 

E. View Policy Settings 

 

The Policy Settings dialog allows you to view the current settings for Rebuild and Verify 

operations for SAFE volumes, including:  

Init Rebuild: Defines whether to automatically copy (mirror) the contents of Disk 0 to Disk 

1 whenever a new SAFE volume configuration is created. When this policy is 

“Enabled”, the data from Disk 0 will be automatically copied (mirrored) to Disk 1. 

When this policy is “Disabled”, no automatic copy is performed.  

Auto Rebuild: Defines whether to remember the non-usable state of a hard drive if it is 

disconnected and then re-connected to the SteelVine Storage Processor. When this policy 

is “Enabled”, the system will always attempt to rebuild a disk that has been inserted, 

even if that disk had previously been identified as non-usable. When this policy is 

“Disabled”, the system will not rebuild a disk that had previously been identified as non-

usable.  

Verify Rebuild: Defines whether to automatically perform a verification of the data after a 

rebuild operation is completed. When this policy is set to “Enabled”, a verification of 

the copied data is automatically performed. When this policy is “Disabled”, an 

automatic verification of the copied data is not performed, and any verification would 

need to be launched manually through the SteelVine Manager GUI.  

These settings are set in the hardware of the PopDrive and cannot be modified through the 

SteelVine Manager GUI.  

 

Use the following procedure to open the Policy Settings Dialog.  

1. Click on the Policy Settings icon along the top of the SteelVine Manager Status 
window.  

 

2. When prompted, enter the administrator password. The default password is admin.  
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3. The Policy Settings dialog shown below will appear.  

  
 
For more information about how manually rebuild and verify a SAFE volume, refer to the following 

sections: Rebuilding Drives, Manual Verification, and Scheduled Verification. 

F. Rebuilding Drives 

Note: This set of features is only enabled when exactly one SAFE volume exists.  
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Start Rebuild  

If the hard drive should fail in any way, the SteelVine Manager is set up by default to 

automatically begin the rebuild process. Once the Rebuild and Verify operation has been 

completed, the disk will be available for optimal use.  

When exactly one SAFE volume exists, you can request a drive rebuild if the disk was marked 

bad or a previous rebuild operation was aborted. To start the rebuild, select Action > Start 

Rebuild > Select Drive n. Once a rebuild process has been started, it can also be aborted.  

 

Once the rebuild has taken place, the Verify process will begin automatically if your system is 

configured to do so. If the rebuild process is ever interrupted, the rebuild process will resume from 

the last 10 GB segment that was completed before the interruption occurred. 

Abort Rebuild  

To abort a rebuild process that is already active, select Action > Abort Rebuild. The rebuild process 

will be terminated, and the SAFE volume will remain in a degraded (vulnerable) state until the 

rebuild is restarted and allowed to complete. 

 

G. Manual Verification 

 

To confirm that the two hard disks that comprise a single SAFE volume are exact copies, you can 

also execute a Verify Disk task manually.  
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When the SteelVine Storage Reference Design is powered on and you select “Start Verify”, 

there is a 60 second delay. The “Start Verify” selection will be disabled during this time. 

Otherwise, if the drive is in normal or verify abort mode, you can manually start the verify 

operation.  

 

A pop-up will inform you of the action taking place. 
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H. Scheduled Verification 

Create a New Schedule  

The SteelVine Manager software is set up to automatically verify the rebuild of a hard disk drive. 

However, you can also create a verification schedule at your discretion.  

The schedule can be set for daily, weekly, or monthly. The default setting is weekly. It can be 

customized to run during the off-hours so as to not interfere with your normal back-up routine. A 

schedule can be run for each individual hard drive.  
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Modify/Delete Verification Schedule  

You can modify or delete an existing schedule by selecting the desired radio button, then changing 

the parameters and clicking the OK button. 

 

I. E-Mail Notifications 

Overview  

The Email Notification feature allows you to 

have the SteelVine Manager automatically 

send an email message if any of the following 

conditions or situations occur: Partition 

Rebuild Start  

Partition Rebuild Complete  

Partition Verify Start  Partition Verify Complete  

Partition Rebuild Resume  Temperature Too High  

System Fan Too Slow  Power supply Fan Too Slow  

No Boxes Found  Box Removed  

Drive Unplugged  Drive Inserted  
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Each of the above conditions can be customized for sending options as well as the 

message that is sent. 

Accessing the Email Notification Dialog  

Use the following procedure to enable the security feature and lock all of the hard drives.  

1. Click on the Configure Email Notification icon along the top of the SteelVine Manager 

Status Window or select the Setup Email Notification item from the Edit menu pull-down 

list.  

 

2. Enter the Administrative password for your system (the default password is admin).  
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3. The Email Notification setup screen show below will appear.  
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Setting-up Email Notification  

1. Enter the hostname or IP address of the SMTP server. If you leave this blank, the 

SteelVine Manager will perform a DNS lookup and will attempt to find the address of the 

SMTP server automatically.  

 

2. Enter the SMTP Server Port number or use the default value of Port 25.  

 

3. Enter your full email address into the From box, and enter the full email address(es) of the 

intended recipient(s) of the condition notifications into the To and CC boxes.  

 

4. Click on the “Test Email” button at the bottom of the screen to verify that you have 

correctly set-up the email portions of this feature. You may need some assistance from 

your network administrators if you have any problems.  

5. For each error condition or event item, you can use the “When to send” radio button items 

to specify the frequency of sending an e-mail notification message to prevent a flood of 

email messages, especially when the same error condition or event occurs multiple times.  

6. The Email Notification feature also you to customize a message for each of the error 

condition or event items (of which each has its own default message already built in). For 

example, use the following procedure to edit the message for “Drive Unplugged”.  

• Click on the “Message” button.
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• The following dialog will appear:  

 

• The message information can be customized to suit your needs. The Daemon can 

extract the following data from the SteelVine hardware:  

 

J. Pop-Up Error Notification 

Overview  

You can enable or disable the Error Popup Notification. The default setting is that this feature is 

enabled and set to display for 30 seconds. Popup messages can appear for up to 60 seconds.  

To set the option for manual closure of the pop-up window, set the seconds to “0”. This will keep 

the pop-up window from closing until you click OK to dismiss the pop-up message.  
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Accessing the Pop-Up Error Notification Dialog  

Use the following procedure to enable the security feature and lock all of the hard drives.  

1. Click on the Pop-Up Error Notification icon along the top of the SteelVine Manager 

Status Window or select the Configure Pop-Ups item from the Edit menu pull-down list.  

 

 

2. Enter the Administrative password for your system (the default password is admin).  

3. The Pop-Up Error Notification setup screen show below will appear. You can Enable or 

Disable the popup message by selecting the appropriate radio button. You can also 

specify the duration of the display time for the popup messages.  

 

4. Click “OK” to save your settings.  

K. SteelVine Administration 

This section explains how to perform administrative functions in the SteelVine Manager.  

Changing the Administrative Password  

The SteelVine Manager restricts configuration access with a password prompt. The password 

information is stored locally on the host running the daemon. The default password is admin. 

See to the Manage the Client Connection Daemon section for a description of the daemon.  
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1. Select Change Password from the File menu.  
 

 

2. Enter the current password (or use admin if you have not changed the default 
password) and click OK.  

 

3. Enter a new password of five or more characters in both password fields.  

 

4. Click OK to save the new password.  
 

Manage Configuration Files  

The Configuration Wizard provides menus and toolbar buttons to manage configuration files.  

• The Read Config File command in the File menu imports a configuration file so that the 

user can restore a previously saved configuration (storage policy). This feature will only 

be available in the GUI Only mode on the rotary switch.  
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• The Save to Config File command in the File menu exports the SteelVine Storage 

Reference Design configuration to a file.  

 

Each of the procedures in the Basic Configuration section prompts you to save a configuration 

file.  

Import (Read) a Configuration File  

Note: You must have previously saved a configuration file so that one is available to import.  

1. Select Configure Box from the Edit menu or click the Configure Box toolbar 
button to open the Basic Configuration Wizard.  

2. Select Read Config File from the File menu  

 

3. Navigate to the required file and click Open to import it. The Wizard provides 
notice of a successful import and graphically displays the imported volumes.  

4. Click Apply to implement the imported configuration.  

Save a Configuration File  

1. Select Configure Box from the Edit menu or click the Configure Box toolbar button 
to open the Basic Configuration Wizard.  

2. Select Save to Config File from the File menu.  
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3. Navigate to the appropriate directory, enter a file name in the File Name text box, 
and click Save.  

 
 

Manage the Client Connection to the Daemon  

The SteelVine Manager software consists of two modules:  

• Daemon: a background process that establishes communication with the SteelVine Storage 

Processors (implemented as a Service on Windows platforms)  

• SteelVine Manager GUI: an application that provides the graphical user interface  

 

The daemon monitors the status of the PopDrive. By default, the user interface attaches to a 

daemon running on the same host to display the information gathered by the daemon. You can 

configure the user interface to display information tracked by a daemon running on a remote 

host. Having the user interface remote to the daemon allows remote monitoring for system fan 

and hard drive failures. Identification of a failed part may then allow the service provider to 

replace failed components before further complications arise.  

Prerequisites  

Ensure you have the following before you establish the remote connection:  

• The daemon software is installed and running on a host computer connected to the 

PopDrive.  

• The SteelVine Manager GUI software is installed and running on a remote host computer.  
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• A TCP/IP connection can be established between the daemon and the user interface. The 

daemon listens for connections on TCP port 51116. Do not change this port number.  

Set Up a Remote Connection  

1. In the Status Window, select Change Connection from the File menu.  

 

2. Enter the host name or IP address of the host computer on which the daemon is 
installed and enter the default port number of 51116.  

3. Click OK.  

 

The user interface establishes the requested connection and displays information 
gathered by the remote daemon in the Status Window.  

Note: The host name or IP address is not saved across sessions.  

 

Install New Firmware  

1. Select Specify Firmware from the Edit menu of the Status Window or click the 
Specify Firmware toolbar button.  
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2. Enter the current password (or use admin if you have not changed the default 
password) and click OK.  

The Firmware Selection dialog shows the PopDrives that are attached to your host 

system, the integrated circuit (IC) revision, and the current firmware installed on each 

chip type.  

 

3. Select the PopDrive that requires a firmware upgrade.  

4. Click the Browse button next to the Update firmware from file text box, navigate 
to the new firmware file you wish to load from a CD or hard disk, and select the 
desired firmware image file with a .bin filename extension for your specific 
SteelVine chip.  

5. Click Install Firmware to begin the upgrade process. A progress bar along the 
bottom of the dialog box will show the progress of the upgrade process.  

Important: Do not access or power-off the PopDrive while installing the firmware image. The 
firmware installation process takes less than two minutes to complete for a standalone 
system. 

6. After the firmware download is completed, a confirmation dialog appears directing 
you to restart your system. In addition, you should cycle the power on the 
PopDrive.  
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Install New SteelVine Manager Software  

Before you install new software, uninstall the current version. The un-installation process stops 

the daemon so it can be removed along with the user interface. The new version of the daemon 

starts automatically when you install new software.  

Uninstall Current Software  

Windows  

1. Exit the SteelVine Manager GUI.  

2. From the Windows taskbar, select Start > Control Panel > Add or Remove 
Programs.  

3. Select the 57xx SteelVine program and click Remove.  

 

4. Confirm that you want to remove the SteelVine Manager software by clicking Yes.  

 

Mac OS X  

1. Drag the Applications > Utilities > SteelVine folder to the trash to remove the 
GUI modules and supporting files.  

2. Drag the Library > StartupItems > SteelVineDaemon folder to the trash to 
remove the daemon startup scripts.  

 

Install New Software  

For Windows, Mac, or Linux, follow the instructions in the SteelVine Quick Installation Guide for 

your operating system to install a new version of the SteelVine Manager software. 
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L. Monitoring 

Monitor Drive Status  

The color of the drives and the labels in the Status Window indicate the state of the drive.  

Color  Label  Definition  Resolution  

Green  Normal  Drive is active.  No action is needed.  

Gray or Red  Unplugged  

Drive is offline. The color is 

initially gray, and may turn red 

after writing to a SAFE 

volume.  

Secure drive in its bay. Replace 

drive if needed.  

Red  

Needs Rebuild  

Drive is in a failed state. Data 

was written to a  SAFE volume 

while the drive was offline.  

Replace the failed drive.  

Use Bigger Drive  

Drive was replaced with a 

smaller drive. The appliance is 

configured with the SAFE, 

FAST, or BIG storage policy, 

and these policies cannot 

accommodate the smaller drive.  

Insert a drive that is the same size 

as or bigger than the original hard 

disk drive.  

Mismatch  

A drive with an unexpected 

Serial Number was inserted for 

a SAFE, FAST or BIG volume.  

Insert the correct hard disk drive.  

Not Readable  

A bad sector was found on a 

SAFE volume's source drive 

while rebuilding.  

None; the mirror copy cannot be 

completed.  

Locked  

A drive that has been locked by 

a different system has been 

connected to the SteelVine 

Storage Process and cannot be 

used.  

Unlock the drive or use a different 

drive.  

Unavailable  

Drive is connected to the 

second port of the SteelVine 

Storage Processor, but the host 

system is not Port Multiplier 

aware.  

None; the drive cannot be accessed 

from a non-PM aware host.  

Orange  
Rebuilding or 

Verifying  

Drive is being rebuilt or the 

rebuild is being verified. The 

percentage complete also 

appears.  

No action is needed; wait for the 

rebuild or verify operation to 

complete. 

Light Blue  New drive  New drive was installed.  No action is needed. 

Purple  Wrong slot  

Mismatched Serial # and 

Expected Serial # because a 

drive is installed in the wrong 

bay.  

Install the correct drive into the 

bay. 
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Monitor Temperature 

The SteelVine Manager uses the following colors to indicate temperature status inside the 

appliance.  

Color  Value  Definition  Resolution  

Green  Normal  

Both system and power 

supply fans are 

functioning within 

limits.  

None required.  

Red  System  

The system fan is not 

spinning or is spinning 

slower than expected.  

Contact point of sale for 

repair.  
Red  PS  

The power supply fan is 

not spinning or is 

spinning slower than 

expected.  

Red  System + PS  

Both system and power 

supply fans are not 

spinning or are spinning 

slower than expected.  

 

Note: If no fan speed sensor is installed, a value of “n/a” will appear. 
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M. Event Log 

 

Event logs are helpful for troubleshooting and locating a system malfunction.  

1. Select Event Log from the Edit menu in the Status Window.  

 
 

 

The Event Log screen displays a list of events in a table format of columns and 
rows.  

• Date displays the date and time of the event.  

• Box SN and Drive SN display the respective serial numbers for the event.  

• Drive Manufacturer displays vendor information.  

• Message gives an event description.  

2. Click Refresh to update the log or click Close to close the log.  
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N. Features not implemented 

 

While there is a backup button option in the SteelVine manager software, there is no physical 

backup button on the PopDrive. This option will be removed from future versions of the 

PopDrive Management software.  
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IV. Safely Removing the PopDrive from your Computer 

 

When using the USB port 

 

USB 2.0 external devices provide support for “plug & play” connection, so that your USB storage 

device can be connected and disconnected while the computer is running. To prevent data loss or 

other failures, you must follow these steps when disconnecting your USB 2.0 storage device from 

your host computer system. Once the physical USB device is disconnected, any volumes that are 

associated with that device will become unavailable. On Windows systems, the SteelVine Manager 

GUI and daemon software must be stopped before any devices can be disconnected. 

 

Windows Systems  

1) Close the SteelVine Manager GUI and exit the icon in the Notification Tray.  

2) Stop the SteelVine daemon by selecting Start → Program Files → Silicon Image → 

57XX SteelVine → Control → Stop SteelVineService. Note: Before using this procedure in 

Windows Vista, you must disable the User Access Control feature in Vista (refer to your Vista 
documentation for details).  

3) Click on the Eject icon (a small green arrow over a hardware image) in the System Tray 

located in the lower right-hand side of your screen  

 

4) A message will appear listing all of the devices that the Eject icon controls. Click on the 

“Safely remove USB Mass Storage Device” item.  

5) The following message then appears: “Safe to Remove Hardware”. You can now safely 

disconnect the device from your computer.  

Note: If your host USB adapter does not support this feature, the device should be disabled using the 
Device Manager or your system should be shut down cleanly and powered off before disconnecting 
the USB device.  

Macintosh Systems  

 
You must un-mount the hard drive system by dragging the hard drive icon to the trash before 

disconnecting it or powering it down.  

Linux Systems  

 

You must manually un-mount the volume using the appropriate Linux command for your specific 

system type before disconnecting it. 
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When using the eSata port 

 

When using a SATA host connection, the hard disk drives can be hot-plugged or hot-unplugged 

while the system is running. However, to avoid data corruption or loss, care should be taken to 

ensure that the host system is not currently using any drive that is about to be hot-unplugged.  
When using a USB host connection, the hard disk drives should not be hot-plugged or hot-unplugged 

while the system is running. Instead, you should eject the drives or shut down your host system 

before connecting or disconnecting any hard disk drives. 
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V. In Case of Emergency – Don’t Panic 

 

How to recover from a Hard Drive crash 

 

The most important thing to remember is: don’t painc. If the SteelVine manager is indicating that 

one of the two hard drives in your RAID1 array is no longer functioning, then following these 

steps will ensure that you don’t lose the data on the hard drive that is still good. 

At this stage: 

1) DO NOT turn off or log out of your computer. 

2) DO NOT attempt to disconnect the PopDrive. 

3) DO NOT remove any of the hard drives from the PopDrive. 

This is what you should do:  

Step 1) Do you have a replacement hard drive ready to put into the PopDrive? 

 Yes – move on to step 2 

 No – move on to step 1a 

Step 1a) Go to the popdrive.com website and order a replacement hard drive. 

Step 1b) Copy the data on your PopDrive somewhere else. 

 Depending on how much data you have, you may want to copy the data back to a folder 

on the hard drive of your computer, onto a flash stick, or onto another fully operational 

PopDrive. While it is extremely rare for two hard drives to fail within a week of each other, it’s 

better to be safe than sorry. Once you have replaced the hard drive in the PopDrive and rebuilt 

the mirror, you can delete the emergency backup that you are making in this procedure. 

Step 2) Open the SteelVine management software. 

Step 3) Identify and remove the bad hard drive. 

Step 4) Insert the new hard drive. 

Step 5) Rebuild the drive array. 

Step 6) Verify the drive array. 
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Appendix A – Technical Specifications 

 

PopDrive 

Length:   ~6 3/8” 

Width:    4” 

Height:   1 1/8” 

 

Weight (empty)  13 oz 

Weight (w/ 2 hard drives) 21 oz. 

Power:    5v, 2a 

External connectors: eSata – 3Gb/s 

USB2.0 – 480Mb/s 

Hard Drive Requirements 

Width    2.5” 

Max height   10.5mm 

Interface   Sata 

Data capacity   limited only by the operating system of the connected computer 

SteelVine Software Requirements 
Windows Systems  

• Intel Pentium-III 500MHz equivalent or faster  

• Windows XP, 2003 Server, Windows 2008 Server, Windows Vista, or Windows 7 with the 

latest Service Packs  

• CD-ROM drive  

• 64 MB of RAM (minimum)  

• 250 MB of free disk space  

• Super VGA (800 x 600) or higher resolution display with at least 256 colors  

• Mouse or compatible pointing device  

• SATA connection: SteelVine Host Bus Adapter card (part number SV-HBA3124, or SV-

HBA3132) and associated software drivers, or any other third-party SATA host controller 

with Port Multiplier support  

• USB connection: USB 1.0 or 2.0 direct host connection or USB hub  

Macintosh Systems  

• PowerMac G5, MacBook Pro or Mac Pro  

• MacOS X, 10.4.8 (or later)  

• CD-ROM drive  

• Mouse or compatible pointing device  
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• SATA connection: SteelVine Host Bus Adapter card (part number SV-HBA3124 or SV-

HBA3132) and associated software drivers, or any other third-party SATA host controller 

with Port Multiplier support  

• USB connection: USB 1.0 or 2.0 direct host connection or USB hub  

 

Appendix B – Warranty Information 

 

DHK Storage provides a one year warranty on the PopDrive. The warranties for the hard drives 

are covered by their respective manufacturers. For warranty repair on the PopDrive, please see 

the support section of the popdrive.com website. 


